Address Auto Completion Incident - Downstream provider outage.
Incident Report for Borderfree API Status
Resolved
Our service provider has resolved the issue and 'Address Auto Completion' is now functioning normally.

Borderfree Retail.
Posted Apr 07, 2023 - 16:30 UTC
Identified
Due to a fault with one of our localization service providers the 'Address Auto Completion' feature for buyer checkouts is currently experiencing a degradation in service, buyers can manually enter their address and checkout as usual.

All other services are operating normally.

We will provide further updates in due course.

Borderfree Retail.
Posted Apr 07, 2023 - 13:49 UTC
This incident affected: Cross-Border Retail (Localization).